Gena01.com Forum
December 17, 2017, 08:43:29 am *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Search Tags Login Register  
Pages: [1] 2
  Print  
Author Topic: Win32Pad 1.5.3 Feedback  (Read 33830 times)
0 Members and 1 Guest are viewing this topic.
Gena01
Administrator
Sr. Member
*****
Posts: 423



WWW
« on: June 23, 2004, 09:41:09 pm »

Please report feedback on Win32Pad 1.5.3 in this thread.

Gena01
Logged
therube
Full Member
***
Posts: 118



« Reply #1 on: June 24, 2004, 01:18:13 am »

Suggestion.

Option for an Indent string (perhaps a fixed or variable length string).

Set an indent sting = "> "

Then an indent will look like this ...

        > this line is indented.

Or indent string = " ->>"

         ->>this line is indented.
Logged
Robert
Newbie
*
Posts: 29


« Reply #2 on: June 24, 2004, 03:25:00 am »

Quote
(From the 1.5.2. thread)
Hmm...
David, imho a software like this is valuable as far as it stays small and fast, without trying to compete with more powerful text editors.


I totally agree with Raffaele.
Keep up!

BTW, How about my question on searching and replacing tabs, newlines, etc. (posted March 2nd 2004 in the 1.5.0 thread).
Has this been implemented yet? Your answer suggested that you would be interested in this...
Logged
Robert
Newbie
*
Posts: 29


« Reply #3 on: June 24, 2004, 03:48:58 am »

Genadi,

I just checked out the Ctrl-2..8 Shortcuts to set the TAB Width.
I think it might be very convenient if you would make the TAB Width visible in the status bar (just like the nr of pages etc.),
since it would otherwise not be possible to see that you (accidently) changed the actual TAB Width until you open the Options window...

Tanx
Logged
therube
Full Member
***
Posts: 118



« Reply #4 on: June 24, 2004, 11:29:21 am »

Paste bug.

I think, generally, that you are loosing the last newline char when pasting into Win32pad.

Occurs in 1.52 & 1.53.
Did not occur in 1.51.

This had occured in a much earlier build.  I'll try to find I post & post back.


EDIT:  Here it is (full thread linked below) ...

Copy does not append the EOL character.

A copy, then the subsequest paste, looses (or doesn't add) the EOL "character".  I may not be saying or describing it properly, but ...

http://www.gena01.com/forum....1;st=10
Logged
Gena01
Administrator
Sr. Member
*****
Posts: 423



WWW
« Reply #5 on: June 24, 2004, 12:29:46 pm »

Quote (therube @ June 24 2004,12:29)
Paste bug.

I think, generally, that you are loosing the last newline char when pasting into Win32pad.

Occurs in 1.52 & 1.53.
Did not occur in 1.51.

This had occured in a much earlier build.  I'll try to find I post & post back.


EDIT:  Here it is (full thread linked below) ...

Copy does not append the EOL character.

A copy, then the subsequest paste, looses (or doesn't add) the EOL "character".  I may not be saying or describing it properly, but ...

http://www.gena01.com/forum....1;st=10

This seems to be Win98 related. What version of richedit control are you using?

Gena01
Logged
laserlight
Newbie
*
Posts: 32



WWW
« Reply #6 on: June 25, 2004, 03:55:02 am »

hmm... cant seem to duplicate the problem.

I am using Win98 2nd Ed. with riched20.dll version 5.30.23.1200
Logged
therube
Full Member
***
Posts: 118



« Reply #7 on: June 25, 2004, 08:33:23 am »

Ok.  It looks like multiple lines need to be selected.  And this occurs in XP also.

sample code 1=======

LINE1!@#$%^&
LINE2+_)(*&^^

END sample code 1=======


sample code 2 with first two lines copied & pasted =======

LINE1!@#$%^&
LINE2+_)(*&^^LINE1!@#$%^&
LINE2+_)(*&^^

END sample code 2=======


sample code 3, the way it should look=======

LINE1!@#$%^&
LINE2+_)(*&^^
LINE1!@#$%^&
LINE2+_)(*&^^

END sample code 3=======
Logged
therube
Full Member
***
Posts: 118



« Reply #8 on: June 25, 2004, 08:35:41 am »

Not sure if this is a bug or not?

But if you have a selection of text highlighted & hit return, it disappears - acting like a cut.

Should it?  Maybe I just noticed it?
Logged
Guest
« Reply #9 on: June 25, 2004, 06:49:51 pm »

You know what would be nice to have, an "select all" button on the toolbar. I don't like to use my keyboard, TIA! :<img src="http://www.gena01.com/forum/Smileys/default/wink.gif" alt="Wink" border="0" />:
Logged
Gena01
Administrator
Sr. Member
*****
Posts: 423



WWW
« Reply #10 on: June 26, 2004, 10:37:51 am »

Quote (therube @ June 25 2004,09:33)
Ok.  It looks like multiple lines need to be selected.  And this occurs in XP also.

sample code 1=======

LINE1!@#$%^&
LINE2+_)(*&^^

END sample code 1=======


sample code 2 with first two lines copied & pasted =======

LINE1!@#$%^&
LINE2+_)(*&^^LINE1!@#$%^&
LINE2+_)(*&^^

END sample code 2=======


sample code 3, the way it should look=======

LINE1!@#$%^&
LINE2+_)(*&^^
LINE1!@#$%^&
LINE2+_)(*&^^

END sample code 3=======

I tried replicating this, then tried the same thing in other editors. The behavior is the same all over. One thing to check, after you entere line1 and line2, hit enter at the end of the line, then select All and do Copy, then go to the beginning of the file then do paste, it should produce the result you are expecting.

Gena01
Logged
therube
Full Member
***
Posts: 118



« Reply #11 on: June 26, 2004, 05:07:45 pm »

Nope.  You're missing something in my explanation, or I'm missing something in my description.

Try it in 1.5.1 & notice the difference.

Highlight a single line - don't drop down to the next line.  Copy & then do some pasting.

Highlight a single line, but do drop down so the highlight sits at column 1 of the next line.  Copy & then do some pasting.

Compare what you get with 1.5.1 to 1.5.3.


EDIT:  I notice (& I can only comare 1.5.3 & 1.4.2 at the moment) that 1.5.3 uses "text" in the copy, & 1.4.2 uses "rtf", if that makes any difference?  Reviewing the .CLP's, other then the format that they are in, I don't see any difference in what is actually copied.  VIM (text editor) copies in the same fashion as 1.5.3.  So I'm thinking that there is just a missing new-line char $0d0a$ that is not being added after that paste is pasted & it should be?
Logged
Guest
« Reply #12 on: June 29, 2004, 04:41:15 pm »

Just tried the editor now (after finding out about your site in Miranda's msgboard).   Good work.  I always liked small and fast programs that don't use the registry.

Shouldn't someone start a "registry and junk free" emblem program? :)

Some question/suggestions;

* It seems the implemented wheel scrolling is of the "delayed variant" and not the instantaneous kind which I think is better.  Is it possible to change that, or add a configuration option?

* It'd be nice to have the cursor change (to a full box) when in overwrite mode.  I never liked the MS way. (They did it right in their DOS editors, but not Windows).

Also, the cursor should stay visible on selections.

And a silly thing, but would it be possible to make the cursor 2 pixel wide? :)

* Having more color configuration, like for selected text (blue background for both selected and unselected doesn't work too well).

* I also noticed what therube mentions.  Copying excludes the last CRLF.  Starting from an empty file, here's how to reproduce it:
  
  line1
  line2
  

Select all (ctrl+a) works fine, though.

Cheers.
Logged
Guest
« Reply #13 on: June 29, 2004, 04:44:30 pm »

The "reproducing" part at the end of my previous msg didn't show up right.  HTML-like brackets was removed, so here it is again:

  line1 [enter]
  line2 [enter]
  [shift+ctrl+home] [ctrl+insert] [ctrl+home] [shoft+insert]
Logged
Gena01
Administrator
Sr. Member
*****
Posts: 423



WWW
« Reply #14 on: June 29, 2004, 08:24:02 pm »

Quote (Guest @ June 29 2004,17:44)
The "reproducing" part at the end of my previous msg didn't show up right.  HTML-like brackets was removed, so here it is again:

  line1 [enter]
  line2 [enter]
  [shift+ctrl+home] [ctrl+insert] [ctrl+home] [shoft+insert]

I was able to reproduce this and find the problem.. Ooops..  Ctrl+V works, Shift+Insert doesn't.. It shall be fixed in the next release.

Thank you.

Gena01
Logged
Tags:
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines | Sitemap Valid XHTML 1.0! Valid CSS!